آماده سازی افزونه های قبلی برای فایرفاکس 3.0

فرستاده شده: ژوئیه 13, 2008 توسط itstart در Uncategorized

اگر شما یکی از کابران مروگر پر طرفدار و محبوب فایرفاکس باشید، احتمالا با مهاجرت از نسخه های پایین تر به نسخه ی جدیدتر 3.0 گهگاه با مشکل عدم سازگاری افزونه های قدیمی با نسخه جدید روبرو شده اید.
راه حلی که در اینجا بیان می شود در بیش تر موارد می تواند به کمک شما بیاید و شما را قادر خواهد ساخت تا آن ها را بر روی نسخه جدید نیز نصب کنید و اگر کمی شانس هم با شما یار باشد می توانید از آن ها به خوبی قبل استفاده کنید.

  1. افزونه ی مورد نظرتان را که فایلی با پسوند xpi را با Winzip یا هر برنامه ی دیگری که توانایی گشودن فایل فشرده سازی شده با الگوریتم ZIP هستند، باز کنید.
  2. از میان فایل ها و فولدرهای موجود فایل install.rdf که قابلیت ویرایش توسط یک ویرایشگر ساده متنی نظیر notepad دارد را باز کنید.
  3. در این فایل دو Node با نام های minVersion , maxVersion تعبیه شده که حداکثر و حداقل محدوده ی نصب افزونه را تعیین خواهد کرد.
  4. با تنظیم maxVersion مقدار به 3.0 و ذخیره ی مجدد ای فایل (install.rdf) در افزونه، اجازه ی نصب آن را بر روی فایرفاکس نسخه ی 3.0 خواهید داشت.

نکته ی پایانی: علاوه بر مشکل نصب که با راه حل بالا رفع می شود مشکل دیگر عملکرد صحیح افزونه ی مورد نظر در نسخه ی جدید است که مستلزم آن است که در توابع به کار رفته در افزونه با تغییرات در نسخه جدید سازگار باشد. که البته در اکثر موارد اینگونه نیز هست.

Advertisements
دیدگاه‌ها
  1. alireza می‌گوید:

    salam khub bud

    khune tekuni mobarak bashe

    faghat tu ghesmate nazarat parantezaye Mail kharab shode
    😉

  2. […] بر این نسخه آپدیت شده می باشد که می توان با نکته ای که (اینجا) ذکر شد آن ها را رفع […]

  3. محمدرضا می‌گوید:

    یه روش دیگه هم برای اینکار وجود داره که خیلی راحتر است.
    به نوشتن عبارت about:config در آدرس بار به بخش تنظمیات فایرفاکس برید.
    روی یه بخش خالی صفحه کلیک راست کرده و گزینه New و سپس Boolean را انتخاب کنید.
    حالا در کادر باز شده عبارت extensions.checkCompatibility را بنویسید و OK کنید و در پنجره باز شده بعدی گزینه false را انتخاب کنید.
    از این بعد تمام افزونه های ورژنهای قبلی را به سادگی میتونید نصب کنید.
    اگر هم خواستید این امکان را غیر فعال کنید بایستی کلیدی که ساختید را غیرفعال کنید یا کلا پاکش کنید.

پاسخی بگذارید

در پایین مشخصات خود را پر کنید یا برای ورود روی شمایل‌ها کلیک نمایید:

نشان‌وارهٔ وردپرس.کام

شما در حال بیان دیدگاه با حساب کاربری WordPress.com خود هستید. بیرون رفتن / تغییر دادن )

تصویر توییتر

شما در حال بیان دیدگاه با حساب کاربری Twitter خود هستید. بیرون رفتن / تغییر دادن )

عکس فیسبوک

شما در حال بیان دیدگاه با حساب کاربری Facebook خود هستید. بیرون رفتن / تغییر دادن )

عکس گوگل+

شما در حال بیان دیدگاه با حساب کاربری Google+ خود هستید. بیرون رفتن / تغییر دادن )

درحال اتصال به %s